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Part 0: Introduction
This document follows my efforts to build tracks of increasing complexity, from a simple fantasy
rally stage to a real-world circuit with multiple layouts. It's also designed as a tutorial so that
others walking this path have an easier time than me.

Assumptions
● You know how to turn on file name extensions in Windows
● You use some kind of backup service so you are protected from lost/corrupted files
● You own Assetto Corsa and can locate ksEdit.exe in its sdk folder
● You use Content Manager to run Assetto Corsa
● You have purchased and installed Race Track Builder, and even though you know the

help file is in steam\steamapps\common\Race Track Builder\Help.html, you still have no
idea how to build a track

● You have followed the directions for obtaining Google API keys for Google Maps Images
and Elevation and have them in hand

● You know the difference between a text editor (e.g. Notepad++) and a word processor
(e.g. MS Word)

● You have a little experience using GIMP or some other image editor

Abbreviations
● AC - Assetto Corsa
● CM - Content Manager
● RTB - Race Track Builder
● XPack - exPansion Pack
● LMB - left mouse button
● MMB - middle mouse button
● RMB - right mouse button
● WHEEL - mouse scroll wheel

Semantics
● Keyboard key names are in bold capitals, likeW, CTRL, and DEL
● Mouse actions are in bold, like RMB except click, which means LMB
● Directory and file names are generally highlighted and show extensions
# Text in config files is displayed like this



Part 1: Hello World
As the title suggests, the goal is to create a simple track that demonstrates that you can build a
track in RTB and drive it in AC.

Part 1.0: Get Organized

Project Name
Choose a simple yet personal name for your project that uses a mixture of lowercase letters,
underscores, or numbers. Don't put spaces in the name. Don't use capital letters. You will be
able to give your track a proper description later. For the first project, I'm using my initials
followed by a minimally descriptive name: ik_helloworld.

Folders
Building tracks is a complex, time-consuming endeavor. There are lots of folders and files to
manage. Here's how I organize my Documents folder. The Assetto Corsa folder is managed by
AC. The Race Track Builder folder is the default location where RTB puts its projects. The
Trackcraft folder is where I assemble the various components to make a track that can be
imported into AC. Notice the various places where the project name is used.

● Documents\
○ Assetto Corsa\
○ Race Track Builder\

■ ik_helloworld\
● Export\

○ ik_helloworld
■ ik_helloworld.fbx
■ ik_helloworld.fbx.ini

● Plugins\
● Xpacks\

○ Trackcraft
■ ik_helloworld\

● ai\
● data\
● texture\
● ui\
● ik_helloworld.kn5



Part 1.1: Get XPacks at RTB Workshop
RTB comes with some graphical assets like buildings and trees, but you will probably want
more. You can find assets built by the community in the Steam Workshop. You can also build
your own assets, but that is a topic for later.

Go to the Steam Workshop for Race Track Builder and subscribe to some expansion packs
(XPacks). You can find these in Community Hub -> Workshop -> Browse. Click on the
checkboxes to subscribe. We are going to use "LoRes Cars by Nobby 76" because every rally
track needs a broken down car on the side of the road, so make sure to subscribe to that one.



Part 1.2: Create New RTB Project
Launch RTB and you will be presented with a window titled "Create New or Open Venue".

● Fill in your project name (e.g. your initials followed by helloworld)
● Choose Yorkshire Dales as the setting
● Set the sliders for Width and Depth to the minimum1

● Choose Target: Assetto Corsa
● Choose a background size of 2048 and a Mask Size of 1024
● Select the RTB Google Maps API and Elevation API
● Copy-paste your API key (it's the same for both)
● Latitude, Longitude: 39.0243349,-122.4533933
● Quality: Medium (again, for demo purposes)

After hitting the OK button, you will be presented with the main RTB view. This will start to fill in
with the terrain as RTB fetches images from Google. Note that the menu at the top is hidden
until you mouse over it.

1 The Background Size (512 - 16,386) and Quality (Low, Medium, High, Very High) are used to create an
image file stored in: your_project_name\XPacks\MyPack\Textures\BackgroundMap.png. The size of the
file depends mostly on the Background Size. If you choose 1024, you will end up with an image that is
1024x1024 and takes up ~2M of space. Using larger sizes increases the size of the file. 2048x2048 is 4
times larger (~8M), and 4096 is another 4 times larger (~32M). Increasing the quality also increases the
file size, but only a little. If you choose a very large size and high quality, it will take a long time for RTB to
download all the images from Google to build your BackgroundMap.png.



Moving Around the Main Interface
● To move the terrain in the X-Y directions, hold MMB and drag
● To zoom in/out, useWHEEL
● To rotate, hold the RMB and drag
● To move, zoom, or rotate faster, hold the SHIFT key while performing other actions

Project Directory Organization
By default RTB projects are in Documents\Race Track Builder and have the following structure.

● ik_helloworld (name of the project)
○ Plugins (folder we won't be using)
○ XPacks (folder that will fill up with some things)

■ MyPack (folder specific for this project)
■ Yorkshire Dales.zip (compressed folder from RTB)

○ UserSettings.xml (file we will not be editing)
○ Venue.bin (file we will not be editing)



Part 1.3: Refine Terrain
Move your mouse to the top left of the screen and click on the green mountain on the far left.
This is the Terrain tool. There are 3 sub-tools associated with Terrain. The first one we will use is
the add/delete tool on the far right.

Click on the add/delete tool and then hover your mouse over different parts of the map. If you
click on green triangles, you add new areas to the map. If you mouse over existing regions, they
turn red. Remove triangles by hitting the DEL key. To show/hide the wireframe, use theW key.

The wire frame shows that the map begins with very
low resolution. To increase resolution, choose the detail
tool, which comes in two types: circle or triangle. The
triangle tool sub-divides each triangle into smaller
triangles. The circle modifies all of the triangles in its
range. Let's use the circle.

In order to add detail to the terrain, you must increase
the resolution of the circle tool (which decreases its
diameter). While holding the CTRL key, swipe your
mouse left and right. This changes the size of the circle
hovering around your mouse. Make the circle smaller
and try clicking or dragging around the map. You'll see
the map increase the resolution of the underlying
wireframe. If you don't see the wireframe, toggle it back
on with theW key. Using a medium-sized circle, convert



all of the terrain. Change to a higher resolution near the dirt road and go to maximum resolution
at the edges of the road. After a bit of editing, my terrain looks like this.



Part 1.4: Create Track
To start building the track, select the blue track tool. Then click on the "add a track" button and
then choose the Cardinal type in the drop-down. Use the default values for surface, camber, etc.

Initiate the track near the "parking lot" with a click, and then click again a little further up the
road. Keep clicking along the road to make it follow the path of the road. Don't worry too much
about the accuracy of your clicks as you sketch out the track.

Next, choose the second button to move the nodes of the
track. Zoom in and reposition the nodes to more accurately
position the road on the terrain.

● Move nodes by click-n-drag
● Add new nodes with CTRL + LMB
● Remove nodes by selecting with LMB and then DEL
● Recall your map interface actions

○ To move the terrain in the X-Y directions, hold MMB and drag
○ To zoom in/out, useWHEEL
○ To rotate, hold the RMB and drag
○ To move, zoom, or rotate faster, hold the SHIFT key



Part 1.5 Add Objects
The Yorkshire Dales setting already has some objects, but let's do something more interesting
and put something from an XPack into the scene. In the RTB menu, select Edit -> XPacks...

Choose the "LoRes Cars by Nobby 76" by selecting its checkbox.

To place objects in the scene, we use the red tool in the middle. Select the "Add a new object"
and use the Single Object type.

Choose "Car" from the drop-down and you will see several car models to choose from. Feel free
to click whichever one you like.



Click in the scene to place your vehicle. I placed the car in the parking lot on the left side of the
track.

Notice that the object isn't placed perfectly. The left rear wheel appears to be in the dirt. To
reposition your object, choose the 2nd tool to move existing objects. This will show some axes
on your object. If you have multiple objects in your scene, clicking them brings up their axes.

● Dragging the arrow heads will stretch the object, making it taller, wider, or longer
● Dragging the straight lines will move the object in space
● Dragging the curved lines will rotate the object around the gray ball axis
● Hitting the DEL key removes the object

In order to place the object accurately in the scene, you may need to zoom in a lot and make
very small adjustments to the various axes.



Part 1.6 Add Gates
The Start and Finish locations are created with the
Grid / Timing Gates tool. As soon as you click this,
you will see a lot of colored cars. These are the
positions of the cars in the pits and the starting grid.
We don't need any of that right now. Reduce the
number of Teams to 1 and also click the checkbox
For Rally. This will greatly simplify the interface.

The image below shows all of the elements in play.

● The START gate is where timing begins
● The FINISH gate is where timing ends
● There are also 2 CHECKPOINT gates used for split times
● The YELLOW vehicle represents the car in the starting grid
● The PURPLE vehicle represents the pit position, which I placed in the parking lot
● The ORANGE vehicle represent the hot lap position, which doesn't make sense for rally,

so it's off to the side
● The BLACK vehicle was the object we put in the scene just for fun

Your display will look very different from what is shown above. If you don't see the START or
FINISH gates, rotate the map. These are direction-specific images, and it may be that your
START or FINISH is pointed in the wrong direction. If this is the case, drag the cyan cars around
to reposition the gate. You can also click the gate itself, and it will move along the length of the
track. Click and drag the various cars to reposition them and double-click to change direction.

After moving the gates to their final positions, the track looks like the images below.



This last image is pretty cool because it shows the
track twisting over a wireframe of the terrain. I
think I'll use that as the track preview image later.



Part 1.7 Export FBX
Choose Export... from the File menu as shown. Leave all of the default settings and hit the OK
button to proceed. From the same menu, Save your project and then Exit. We are done with
RTB for now.

You now have a new folder in your project called Export. Inside this is a critical file called
ik_helloworld.fbx (it's a good idea to always show file extensions, so turn that on if it is currently
off). Here's what your project folder looks like now.

● Documents\Race Track Builder\ik_helloworld
○ backups
○ Export (new folder)

■ ik_helloworld
● texture (folder with lots of files)
● ik_helloworld.fbx (file to be imported into ksEditor)
● ik_helloworld.fbx.ini (file we won't be editing)

○ Plugins (empty folder)
○ XPacks

■ MyPack (folder)
■ LoRes Cars by Noddy76.zip (compressed folder)
■ Yorkshire Dales.zip (compressed folder)

○ UserSettings.xml
○ Venue.bin



Part 1.8: Create AC Track Folder
Copy the Empty Track Template provided by RTB to wherever you want to build the final version
of the track. If you're following my organization, this is in Documents\Trackcraft. Rename the
folder so that it matches your project name. To be explicit, here are some more complete paths.

steam\steamapps\common\Race Track Builder\Support\Assetto Corsa\Empty Track Template
Documents\Trackcraft\Empty Track Template (before renaming)
Documents\Trackcraft\ik_helloworld (after renaming)

Here's what's in your track folder right now. The highlighted items will be changed.

● ai\ - empty folder
● data\ - folder with many files
● texture\ - empty folder
● ui\ - folder with 3 files we need to edit
● map.png - to be deleted

Delete map.png
The map.png provided doesn't match our track, and we don't need a map yet. Delete the file.

Create PNGs

The ui\review.png is usually focused on some iconic feature of the venue. This might be a
building, a specific corner, or a panoramic view. The usual image is 355x200, 72 dpi, and 24 bit
color, but these specifics are not requirements. I'm using the wireframe image from Part 1.6.

The ui\outline.png is usually 32 bit RGBA with a fully transparent background. The dimensions
are typically small, but are also not regulated. The outline
will be centered over the preview. In GIMP, select File ->
New... then click on the Advanced Options. In the example
here, I entered 200 for Width and Height, and Fill with:
Transparency. The track outline is usually white over a
transparent background. I drew a squiggly white line. When
you're done, choose File -> Export as... and make sure you
have RGBA selected as shown below.



Edit JSON
Edit the ui\ui_track.json file provided to your liking.

● Change "name" to the title of your track
● Add a "description" if you like
● You can add "tags" to allow users to sort and find tracks efficiently
● The "circuit" tag is required (for reasons I don't currently understand)
● I don't know how "geotags" are supposed to be used
● Feel free to add more information, including adding a new tag for your name as the

"author"

{
"name": "Hello World",
"description": "Minimal rally stage for demonstration",
"tags" : ["circuit", "rally", "USA"],
"geotags": ["39.0260352", "-122.4528730"],
"country": "USA",
"city": "",
"length": "",
"width": "",
"pitboxes": "1",
"run": "clockwise",
"author": "Ian Korf"

}



Part 1.9: Create KN5 with ksEditor
Start the ksEditor application. Choose File -> Open FBX and then navigate to the FBX file you
created in Part 1.7.

Choose File -> Save KN5. Name the file your equivalent of ik_helloworld.kn5 in the equivalent
location of your Trackcraft\ik_helloworld folder.

That's all we're doing in ksEdit. Leave with File -> Exit.



Part 1.10: Test Drive
Copy the entire contents of your Trackcraft/ik_helloworld folder to your AC tracks folder. Here
are the more complete paths.

source: Documents\Trackcraft\ik_helloworld
target: steam\steamapps\common\assettocorsa\content\tracks\ik_helloworld



Part 2: Circuit Demo
https://assettocorsamods.net/threads/how-can-i-make-ai-path.234/
Cameras...

Part 3: Hill Climb

Part 4: Race Track


